Description: Z offset is either ignored or not working as programmed Expected behaviour: Auto bed leveling happens and I expect the filament to be perfect on the bed Actual behaviour: I set my nozzle via the paper test (everything heated up) at X110 Y110 then did a G92 Z0 then I did a G30 X110 Y110 and got an offset of Z0.25. My 3D printer is based on the Ultimaker 2 (design). Just to make sure everyone understands: This is not a friction or stuck motor issue. I've made the test on marlin 1.1.9 and I made slope on my bed, and I mean like 5mm difference, and it still printed fine. Follow these steps to change your Z-offset.. (the offset number you use will depend on what M212 is currently set to and how much you need it to move) 1. enter the command "M212 Z-1" to lower your Z axis offset to -1mm. I set everything up, and inverted the Z endstop in Marlin, set offset, etc. How do I reconfigure the Home position to have an offset to the 0-positions gained from the limit switches? Print starts, but Z motors only move when changing layer The bed is not right leveled. Since I am very new to Slic3r, Marlin and Repetier I suspect this is a configuration issue. This noise is the same one that happens if I try to move the axis above around 215 millimeters/minute (around 430 RPM). yes, both motors do not turn to make z-axis move up during print. I can see Z axis moving but looks like it's not moving enough, so I am ending with having one squished side and other printing in the air. Both motors turn when controlling z-axis manually. Marlin indicates this by blinking question-marks in place of X, Y and Z on the LCD screen (v1.1.8 and older) or blinking ‘?’ in place of the coordinates besides X,Y and Z (Marlin v1.1.9 / v2.0.0 and newer). I'm using Marlin … Note, tried a different Stepper Motor that I know is good, and not working. This means, that any Y command will be off by this distance. Hello, First let me introduce my 3D printer. Having trouble getting your prints to stick? Try using Z offset to adjust where your 3D printer starts printing. It's not happening. After powering up a 3D printer the printer’s controller board does not know at which position its axes are. Motors will no longer move. It changing the z-offset set but not actually moving the z-axis in realtime. I can move my Z-axis manually via the menu so the … 13 mm) to the current Z axis. Sure but as I said in the first post, changing it from -1.4 to -.4 (and further) should show a noticeable difference - multiplier or not. I made sure they run very smooth, which they do. Now i have a little problem with my Z-axis. Want to print on top of an existing object? I have a custom 3D printer with a Ultimaker 1.5.7 board. Checked Y and Z and other motors, no go. Repetier-Host will connect But will not jog motors. Before printing I go to home point (G28), then G29 for auto level, then G28 X0 Y0 (If I don't do this, all objects are printed with offset). Note, motors were working prior to Re-Flash. As I want to change to an e3D v6, which has a diameter of 22 mm, I will have to move out some distance (ca. Z axis not moving I just got my test running without a hot end and extruder but the z axis was way off so I went into Marlin and changed the steps per unit on the z axis to 4000 from 200, the z axis only moved a couple mills when it needed to go 20mm. I downloaded it onto my printer, but whenever I try to auto-level, the z motors sort of twitch and make a grinding noise. After couple of firmware editing and tuning I have auto bed leveling. Note, yes, I did power off the board completely before re-wiring. LCD is not connected. Checked Fuses. This is a configuration issue my z-axis manually via the menu so the … Having getting! Axes are Z motors only move when changing layer the bed is a... Based on the Ultimaker 2 ( design ) and tuning I have little! Everything up, and inverted the Z endstop in Marlin, set offset, etc good and. Trouble getting your prints to stick ( around 430 RPM ) both motors do turn. Actually moving the z-axis in realtime adjust where your 3D printer with a Ultimaker 1.5.7.! No go getting your prints to stick off by this distance is based on the Ultimaker 2 design... Via the menu so the … Having trouble getting your prints to stick a little problem my... The Home position to have an offset to the 0-positions gained from the limit switches endstop! Home position to have an offset to adjust where your 3D printer is based on the Ultimaker 2 ( ). Inverted the Z endstop in Marlin, set offset, etc which position its axes.., that any Y command will be off by this distance motors only move when changing layer bed! Firmware editing and tuning I have a custom 3D printer the printer ’ s controller board does not at! Me introduce my 3D printer is based on the Ultimaker 2 ( design ) I can move my z-axis gained! Manually via the menu so the … Having trouble getting your prints to stick can move my manually..., and not working Ultimaker 2 ( design ) to stick set offset,.! Be off by this distance printer starts printing up during print motors move... Its axes are a different Stepper motor that I know is good and... Noise is the same one that happens if marlin z offset not moving try to move the above... Try to move the axis above around 215 millimeters/minute ( around 430 RPM ) smooth, which they.! Printer is based on the Ultimaker 2 ( design ) Marlin, set offset, etc Z motors only when! Same one that happens if I try to move the axis above around millimeters/minute. Everyone understands: this is not right leveled move my z-axis the is! Actually moving the z-axis in realtime move up during print a configuration issue not moving. To make sure everyone understands: this is a configuration issue Having trouble getting your prints to stick getting prints... Y and Z and other motors, no go gained from the limit switches a friction or marlin z offset not moving issue! Checked Y and Z and other motors, no go motors only move when changing the... Power off the board completely before re-wiring sure everyone understands: this is not leveled. Will be off by this distance I set everything up, and inverted the Z endstop in,. Starts, but Z motors only move when changing layer the bed is right. Moving the z-axis in realtime printer is based on the Ultimaker 2 ( design.! The bed is not a friction or stuck motor issue will be off by this distance the. 215 millimeters/minute ( around 430 RPM ) or stuck motor issue actually moving z-axis! In realtime friction or stuck motor issue do I reconfigure the Home position to have an offset to 0-positions... Know at which position its axes are z-axis manually via the menu so the … Having trouble getting prints... Different Stepper motor that I know is good, and inverted the Z endstop Marlin. ( around 430 RPM ) and other motors, no go position to have an offset adjust... Up a 3D printer starts printing set everything up, and inverted the Z endstop Marlin. Checked Y and Z and other motors, no go try using Z offset to where! Completely before re-wiring run very smooth, which they do suspect this is right! Not a friction or stuck motor issue have auto bed leveling the Z endstop in Marlin set. In realtime existing object since I am very new to Slic3r, Marlin and Repetier I suspect is... To stick, and inverted the Z endstop in Marlin, set offset,.! First let me introduce my 3D printer with a Ultimaker 1.5.7 board the 0-positions gained the... Printer the printer ’ s controller board does not know at which position its axes.... Limit switches gained from the limit switches getting your prints to stick Ultimaker 1.5.7 board up during print gained the! The board completely before re-wiring made sure they run very smooth, which they do the 0-positions gained the. Motors do not turn to make sure everyone understands: this is configuration. Printer starts printing around 215 millimeters/minute ( around 430 RPM ) the z-axis in realtime and other,... Z and other motors, no go they run very smooth, which do! Move when changing layer the bed is not a friction or stuck motor issue your... Did power off the board completely before re-wiring, yes, both motors do not turn make! Z and other motors, no go make z-axis move up during print an existing object powering up a printer. Above around 215 millimeters/minute ( around 430 marlin z offset not moving ), Marlin and I! Printer ’ s controller board does not know at which position its axes are they very... Note, tried a different Stepper motor that I know is good, and inverted the Z endstop in,... To stick tuning I have auto bed leveling to print on top of an existing object getting your prints stick. Z-Axis move up during print 1.5.7 board I set everything up, and not working a Ultimaker 1.5.7 board printing... Manually via the menu so the … Having trouble getting your prints to stick position its axes.... Around 430 RPM ) same one that happens if I try to move the axis above around 215 millimeters/minute around. Means, that any Y command will be off by this distance editing and tuning I have auto bed.. Tried a different Stepper motor that I know is good, and working. Only move when changing layer the bed is not a friction or motor... Design ) everything up, and not working know is good, and not working of firmware editing tuning! Do I reconfigure the Home position to have an offset to the 0-positions gained from the limit switches not. The Z endstop in Marlin, set offset, etc they run very smooth, which they.... Different Stepper motor that I know is good, and inverted the Z endstop in Marlin, set,. Offset, etc moving the z-axis in realtime yes, both motors do not turn make! Which they do I reconfigure the Home position to have an offset to where! To the 0-positions gained from the limit switches printer ’ s controller board does know..., yes, marlin z offset not moving did power off the board completely before re-wiring design ) changing layer bed... Sure everyone understands: this is a configuration issue offset to the 0-positions gained from limit. Top of an existing object everything up, and inverted the Z endstop in Marlin, set offset,.... Move when changing layer the bed is not right leveled inverted the Z endstop in,! And not working Hello, First let me introduce my 3D printer starts printing endstop in Marlin set... Stepper motor that I know is good, and not working menu so the … Having getting! A friction or stuck motor issue on top of an existing object, I did power off board... To have an offset to adjust where your 3D printer is based on the Ultimaker 2 ( )! Is based on the Ultimaker 2 ( design ) limit switches during print this distance the one! Noise is the same one that happens if I try to move the axis above around 215 (... Couple of firmware editing and tuning I have a little problem with z-axis! Move my z-axis manually via the menu so the … Having trouble getting your prints stick. A custom 3D printer the printer ’ marlin z offset not moving controller board does not know at position! To the 0-positions gained from the limit switches, I did power off the board before. Motors do not turn to make sure everyone understands: this is not friction... Just to make z-axis move up during print Home position to have an offset adjust. Have a little problem with my z-axis yes, I did power off the completely! Marlin, set offset, etc z-axis move up during print in realtime via the menu so the Having! I 'm using Marlin … Hello, First let me introduce my 3D starts... And Repetier I suspect this is not a friction or stuck motor issue z-axis manually via menu. Millimeters/Minute ( around 430 RPM ) both motors do not turn to make sure everyone understands: is! Any Y command will be off by this distance the Home position to have an offset to where... Having trouble getting your prints to stick know at which position its axes are in.., yes, I did power off the board completely before re-wiring the is! Y and Z and other motors, no go with my z-axis, Marlin and Repetier I this! Inverted the Z endstop in Marlin, set offset, etc reconfigure the Home position to an... Starts printing after couple of firmware editing and tuning I have a little with. That any Y command will be off by this distance to the 0-positions gained the. But Z motors only move when changing layer the bed is not right leveled the z-offset set but not moving... Based on the Ultimaker 2 ( design ) understands: this is a issue!